Cómo instalar una versión anterior de Laravel con composer

En ocasiones cuando estamos desarrollando algún proyecto con el framework de PHP Laravel necesitamos instalar una versión anterior a la actual, en este tutorial te muestro cómo instalar una versión anterior de Laravel usando el manejador de paquetes Composer.

Requisitos previos

  1.  Tener un ambiente de desarrollo como XAMPP, WAMP o Laragon.
  2.  Composer instalado de manera global en el sistema operativo.

Cómo instalar una versión anterior de Laravel con Composer

Para instalar una versión anterior de Laravel desde la raíz de tu ambiente de desarrollo abre una terminal de comandos y escribe la siguiente instrucción:

composer create-project laravel/laravel miproyecto "7.*"

Al final de la línea de este comando notarás las comillas dobles, el número que coloques dentro de ellas es la versión que se instalará, el asterisco significa que descargará la última actualización de la versión. Si por ejemplo necesitas instalar la versión 5.5 debes escribir:

composer create-project laravel/laravel miproyecto "5.5.*"

O si quieres instalar la versión 8 de Laravel en su última actualización en la consola de comandos escribe:

composer create-project laravel/laravel miproyecto "8.*"

Y así se ha instalado un proyecto Laravel con una versión anterior a la actual. Recuerda que en algunas versiones de Laravel tienen requisitos distintos como la versión de PHP, siempre consulta la documentación para que estés seguro que cumples con ellos.

Conclusión

En este tutorial aprendiste cómo instalar una versión anterior de Laravel usando el manejador de paquetes Composer, esto te puede servir para trabajar con una versión específica de Laravel. Si este tutorial te ayudo te invito a compartirlo en tus redes sociales para alcanzar a más personas y si tienes dudas o comentarios déjalos en la caja de comentarios, estaré al pendiente de ellos. Te mando un saludo.

Te puede interesar: Cómo configurar un VPS de Ionos desde cero.

Referencias: https://laracasts.com/discuss/channels/laravel/install-old-version-of-laravel

1 COMENTARIO

Deja un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.